Equals database issues

Incident Report for Equals

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 22:56 UTC

Update

We identified and fixed the issue
Posted Jul 18, 2025 - 22:55 UTC

Update

We have identified the issue and are currently bringing Equals back on line.
Posted Jul 18, 2025 - 22:40 UTC

Update

Viewing workbooks and minor edits to workbooks are currently operational. Other functionality including query runs is unavailable. Our team is actively investigating.
Posted Jul 18, 2025 - 22:26 UTC

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 21:58 UTC

Investigating

We are currently investigating the issue
Posted Jul 18, 2025 - 21:56 UTC
This incident affected: Application, Query Execution, and Scheduled Updates.